数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

Input

第一行输入整数N;;
第二行依次输入N个整数。

Output

第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

Sample Input

10
1 3 22 8 15 999 9 44 6 1001

Sample Output

4 6
22 8 44 6 
1 3 15 999 9 1001

Hint

不得使用数组!

Source

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
int main()
{
    int n,i,a,b,x;
    a=b=0;
    struct node *head1,*head2,*p,*q,*tail1,*tail2;
    scanf("%d",&n);
    head1=(struct node *)malloc(sizeof(struct node));
    head2=(struct node *)malloc(sizeof(struct node));
    head1->next=NULL;
    head2->next=NULL;
    tail1=head1;
    tail2=head2;
          for(i=0; i<n; i++)
    {
        scanf("%d",&x);
        if(x%2==0)
        {
            p=(struct node *)malloc(sizeof(struct node));
            p->data=x;
            p->next=NULL;
            tail1->next=p;
            tail1=p;
            a++;
        }
        else
        {
            q=(struct node *)malloc(sizeof(struct node));
            q->data=x;
            q->next=NULL;
            tail2->next=q;
            tail2=q;
            b++;
        }
    }
    printf("%d %d\n",a,b);
    for(p=head1->next; p!=NULL; p=p->next)
    {
        if(p->next==NULL)
        {
            printf("%d\n",p->data);
        }
        else printf("%d ",p->data);
    }
    for(p=head2->next; p!=NULL; p=p->next)
    {
        if(p->next==NULL)
        {
            printf("%d\n",p->data);
        }
        else printf("%d ",p->data);
    }
    return 0;
}

相关推荐